Docker Community Forums

Share and learn in the Docker community.

Redhat docker pulling error x509: certificate signed by unknown authority


(Taoufik109) #1

Hello,
I have a problem with docker: x509: certificate signed by unknown authority.
I can’t do a pull

docker pull mariadb

Using default tag: latest
latest: Pulling from library/mariadb
3d77ce4481b1: Pulling fs layer
4f6a779d83f5: Pulling fs layer
8c1d272f25d5: Pulling fs layer
672dd5e0b768: Waiting
84a7291b5996: Waiting
92edc8e8d33d: Waiting
f86a82067817: Waiting
8eff7352c12e: Waiting
705e5fd937c3: Waiting
45178761f66f: Waiting
93326b4b133f: Waiting
error pulling image configuration: Get https://dseasb33srnrn.cloudfront.net/registry-v2/docker/registry/v2/blobs/sha256/cb/cb0d69450b8eb22a69e84bd60c8e624164d3f2d8cd1d2a42c9f5b1b525e19bae/data?Expires=1525923887&Signature=Qo0andzhYXYZ-zNIjrWEZicIvLJUuiqTtbvo0SII3pDHa766e0KiQ0b1lFdvN9PfkGgloJ1KT8fZsm83SD0vAFCvAPXCpQwSXw0EayXimyCvcgMwkYyGWjTADGAHVS6Y~oEuwUaTxo25tQqIDJYJ~v5YYV0s~VdyAvuMnPJwpf0_&Key-Pair-Id=APKAJECH5M7VWIS5YZ6Q: x509: certificate signed by unknown authority

I’ve tried


I’ve tried everything on internet to solve this but it doesn’t work for me.

docker --version

Docker version 18.05.0-ce-rc1, build 33f00ce

I’m running docker on redhat 7.4

I have this problem after security service has installed an SSL proxy

Any help please, I’m stuck here since 2 days.


(Bryce Ryan) #2

Hi,

since you’re pulling an image from the Docker Hub, the certificate error appears to be an issue between your workstation and the new SSL proxy you mention, or between the new SSL proxy and the Docker Hub. I suggest having a chat with your local IT admins, since this doesn’t appear to be an issue with docker software itself.