Docker Community Forums

Share and learn in the Docker community.

Release for Raspberry Pi 4 (Raspbian Buster)

Hello,

will there be a Docker packages for raspbian buster?
–> https://download.docker.com/linux/raspbian/dists/

Raspi 4B is out and will be supported by Raspbian Buster. As Rpi4B is available with up to 4GB of RAM, it is perfect for running Docker on it. :wink:

For the Install script:

/etc/os-release

PRETTY_NAME=“Raspbian GNU/Linux 10 (buster)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian

Regards, Mathias

2 Likes

Yep. Please, do it. We really need a Docker with this little monster :heart_eyes::smiling_imp:

I found a workaround:

edit your /etc/apt/sources.list.d/docker.list
from

deb [arch=armhf] https://download.docker.com/linux/raspbian 10 stable

to

deb [arch=armhf] https://download.docker.com/linux/raspbian stretch edge

or create that file if you dont have it.

The run

sudo apt update
sudo apt install docker-ce
sudo usermod -a -G docker $USER

Now reboot and Docker should be working.

2 Likes

It works better for me:

sudo curl -sL get.docker.com | sed 's/9)/10)/' | sh

I checked on Raspberry Pi 4 with Rapsbian Buster and it works well. I found this here.

Thanks for sharing with us, this works in my problem with TelltheBell.

The procedure from leonhess did the job.

Worked for me as well. I bought a Pi 4 especially to run Docker faster and though I’d have to wait for Docker to work until Buster was actually officially released… :wink:

So, Buster Nightly is available now. Just missing stable.

Correct, buster is only in nightly channel. You can use

curl -fsSL get.docker.com | CHANNEL=nightly sh

to install Docker on Raspbian Buster 2019-07-10-raspbian*.img until next stable release of Docker CE.
If you want to install a stable release now, you can use

curl -fsSL get.docker.com | sed 's/buster/stretch/' | sh

which installs 18.09.0 at the moment.

2 Likes

There seems to be a stable version out there now:

https://download.docker.com/linux/raspbian/dists/buster/stable/

Can you please tell me how to install it correctly?
I get Cannot connect to the Docker daemon at unix:///var/run/docker.sock.
Is the docker daemon running?

1 Like

did you start the service sudo systemctl start docker && sudo systemctl enable docker ??

So how do we install - doesn’t seem to be working via apt-get or curl

Is there a file (socket) at /var/run/docker.sock?
What do you get if you type ls -l /var/run/docker.sock?

I used the following line which worked for me, at least with the hello-world container:

curl -sSL https://get.docker.com | sh

from the Tutorial on raspberrypi.org:

thank you for this! this works on my latest windows project with raspberry.