Docker Community Forums

Share and learn in the Docker community.

Relocate ./docker/machine folder

(Douglaswebster) #1

I am new to docker and I’m currently looking at the way things are installed.
I run Linux mint V18.1 on a small ssd and because of this I store all large data files e.g Vbox machines on a seperate large HD. I have created a separate partition on this drive for docker development and have succeeded in moving the docker files from /var/lib/docker to this new partition (see docker info printout below). Now though it seems that docker-machine will start to eat up my ssd drive by putting its files in home/.docker/machine. I have tried to find if there is a way of moving this other than by setting up a symbolic link (which seems to be frowned upon by docker) but have had no success - can anyone tell me how to do this.

Thanks in advance

Docker info file:

Containers: 4
Running: 0
Paused: 0
Stopped: 4
Images: 22
Server Version: 17.03.2-ce
Storage Driver: aufs
Root Dir: /mnt/LinxuData/docker/aufs
Backing Filesystem: extfs
Dirs: 72
Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: bridge host macvlan null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 4ab9917febca54791c5f071a9d1f404867857fcc
runc version: 54296cf40ad8143b62dbcaa1d90e520a2136ddfe
init version: 949e6fa
Security Options:
Profile: default
Kernel Version: 4.8.0-39-generic
Operating System: Linux Mint 18.1
OSType: linux
Architecture: x86_64
CPUs: 4
Total Memory: 7.761 GiB
Name: douglas-linux
ID: *****************************************************
Docker Root Dir: /mnt/LinxuData/docker
Debug Mode (client): false
Debug Mode (server): false
Username: *****************
Experimental: false
Insecure Registries:
Live Restore Enabled: false

WARNING: No swap limit support

(Rentziass) #2

Did you manage to find a solution to this?