Docker Community Forums

Share and learn in the Docker community.

RSH between containers on different hosts does not work (Connection refused)

Good morning,

First at all: yes, I absolutely need to use RSH (no SSH, no “copy” instructions…) between my different containers hosted on several hosts since I am embedding heavy applications which massively use RSH.

Second precision: SSH perfectly works between them…

My architecture

  • Host H1 hosts container C1 (192.168.1.1) which runs Application A1
  • Host H2 hosts container C2 (192.168.1.2) which runs Application A2

H1 and H2 are connected with an ethernet cable (eth1 port on both sides), A1 and C2 communicate with rsh/rcp.
C1 and C2 are built from Centos 7

Command on H2:

[user@localhost ~]$ docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
1b36072bd54e A2_image “/bin/bash” 2 minutes ago Up 2 minutes 0.0.0.0:514->514/tcp, 0.0.0.0:544->544/tcp, 0.0.0.0:1022->22/tcp, 0.0.0.0:1222->222/tcp A2_instance

I installed both rsh and rsh-server in both C1 and C2, and created the following file:

cat /etc/xinetd.d/rsh
service shell
{
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.rshd
disable = no
log_on_success += USERID
log_on_failure += USERID
}

But when I launch either from C1 or from C2, either rsh 192.168.1.1, rsh 192.168.1.2, rsh -l non_root_user@192.168.1.1, rsh -l non_root_user@192.168.1.2, I always get the following message:

192.168.1.2: Connection refused

So, what should I do to solve this problem?

Many thanks !

Regards

I found a first error: I forgot to apply the following instructions:

systemctl start rsh.socket
systemctl start rexec.socket
systemctl start rlogin.socket
systemctl enable rsh.socket
systemctl enable rexec.socket
systemctl enable rlogin.socket

But when I try to execute them, I got the following error message:

Failed to get D-Bus connection: Operation not permitted

Note that I launched the docker with the --privileged flag

Hi jfgineste,
Did you find a solution?

I also have multiple Centos7 containers and need to do the same thing (or with SSH) so the containers on different worker nodes in my Docker Swarm can communicate.

Hoping for a response,
Sam