Docker Community Forums

Share and learn in the Docker community.

Running testcafe tests with --network flag doesn't work but with --link works on jenkins

docker
testing

(Rafazzevedo) #1

Hello all,

I am running some tests in a docker container on jenkins using testcafe. As I need to point the tests to another docker container running as a service I tried first to run both of the containers in the same docker network, --network . I tested it locally first to see if both of the containers could communicate with each other and was running as expected. As soon as I tried to do the same on jenkins, the tests were hanging and never finishing, for some reason, which I initially thought was a problem with testcafe framework.

I was trying to avoid to use the --link as it is a legacy flag and no reason to use it if is going to be removed at some point.

Today I tried to use the --link flag since I was trying to find alternatives to fix my problem and for my surprise, it has worked as expected. So, I am wondering if there is something that I am missing when using the --network flag as this should work exactly like the --link flag but with the option to run multiple containers, share variables, etc…

Does anyone have an idea of what it could be ?