Sending Build Context Hangs

Windows 10 Pro 64-bit on Docker for Windows, Build Beta 15, AMD FX 9590 with 32 GB

Diagnostic: 759E951F-374A-4FD1-B678-1D81EDE13841/2016-06-13_20-29-15

Logs:

[20:28:47.477][ProxyProcess ][Info ] proxy >> POST /v1.23/build?buildargs=%7B%7D&cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=Dockerfile&labels=%7B%7D&memory=0&memswap=0&rm=1&shmsize=0&ulimits=null
[20:28:47.477][ProxyProcess ][Info ] Dial Hyper-V socket ed927f8b-607e-4d20-9e76-7dd03e53260e:23a432c2-537a-4291-bcb5-d62504644739
[20:28:49.123][ProxyProcess ][Info ] proxy >> POST /v1.23/build?buildargs=%7B%7D&cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=Dockerfile&labels=%7B%7D&memory=0&memswap=0&rm=1&shmsize=0&ulimits=null
[20:28:49.123][ProxyProcess ][Info ] Dial Hyper-V socket ed927f8b-607e-4d20-9e76-7dd03e53260e:23a432c2-537a-4291-bcb5-d62504644739

Docker Build Hangs while Building the image. Sourcecode: https://github.com/dariusgm/hive2

In the First run, it could be build sucessfully. I wanted to change the wget to a ADD directly to increase the creation speed. This Failed and “Sending to Docker Daemon” hangs until ctrl+c at a random number of bytes already send. Sometimes more, sometimes less. I reverted my changes, but this did not help. I was able to build this image on a VirtualBox docker-machine on an OSX Host

Same problem here. Did you find a solution?

Thanks

Edit:
I only have this problem when using Bash for Windows 10.
My Docker builds run fine using Powershell.

Confirming that I have the same experience - works in Powershell, hangs when using Bash for Windows 10.

Confirming same here but I’m using powershell and it locks at random number of bytes sent. If I keep running docker build, it finishes one in 10 tries as each time its a different # of sent MB. I my case its ~700MB for the full build context. I have a new release of docker windows (as of today) and the build works fine on amazon’s ami linux. Running in windows 10 freshly patched to activate hyper-v (which I had turned off for vmware). Once it passes the sending context it seems to build reliably.

Confirming the same experience with fully updated Windows 10 Pro when using Powershell. My build is only ~50MB. It does not seem to be dependent on what is in .dockerignore file or if it is there at all

Same issue here.

Running command:
docker build --force-rm=true --no-cache=true -t oracle/database:12.1.0.2-ee -f Dockerfile.ee .

Returns:
Sending build context to Docker daemon xxx.x MB

The send never completes. It hangs somewhere between 40-250MB. I’ve tried from DOS prompt, Admin DOS prompt and from PowerShell. Same behavior in each case. I’m using v1.12.3 (8488) on Windows 10 Pro x64. Any suggestions?

I’m relieved to have found this thread, I thought I was going crazy. I too use the Ubuntu shell to connect to my native Windows $DOCKER_HOST over tcp to localhost. I get the same type of hang when trying to build a local image from any Dockerfile.

The really strange part is this has been working fine for me for over a week, it just stopped functioning yesterday and since then hangs at the same spot Sending build context to Docker daemon.

I can also confirm that running docker build from powershell using the same Dockerfile works fine on the same host.

I can also build remote images fine for whatever reason, list images, essentially every function besides building from a local Dockerfile

Seeing the same error. Docker for Windows version 1.13.0 .

My issue was that I had a sub-directory that was under the same directory that had my docker file in it. This folder had some very large files in it (2GB log files). These files had nothing to do with the docker file or the docker build. They where the log files that my container would then parse when it ran. I move this folder out from under the directory that docker file was in and all worked correctly now. This only caused and issue when I was using docker client in the Ubuntu shell. From power shell or cmd prompt it was slower because of these files but they didn’t not hang.

Help this helps other.

You can also use .dockerignore to accomplish this.