Docker Community Forums

Share and learn in the Docker community.

[SOLVED]Cannot Install docker-ce on Debian Stretch

docker

(Dstudio101) #1

Hi,

I’m following this reference: https://docs.docker.com/install/linux/docker-ce/debian/ for installing docker-ce on my debian stretch desktop.

I prefer “Install Using the Repository” and I have GOOD results following steps 1-5. The problem came when I do an apt-get update I receive this error:

Err:12 https://download.docker.com/linux/debian stretch/stable amd64 Packages
gnutls_handshake() failed: Public key signature verification has failed.
....
W: The repository 'https://download.docker.com/linux/debian stretch Release' does not have a Release file.

I tried to look for solutions on the net and in this forum but I did not see any.

After a while, I realized I can do another install using the section “Install from a Package”. So I go the the link https://download.docker.com/linux/debian/ and look for the .deb file my distro but I don’t see any.

As for the other methods- I prefer not to use them as they have a lot of cautions to mind.

Appreciate any help here.

Thanks,

DS101


(Dstudio101) #2

Interesting…

I just did an installation on another Debian Stretch desktop using the instructions above and for some reason, it worked just like that.

Although they are both Debian Stretch desktops, I know there must be some difference but I’m not that advance to know how to troubleshoot this. Nor do I have any idea where to begin.

There is one thing I did DEFFERENTLY in the previous install – in step 3 I ACCIDENTALLY execute the command

curl -fsSL https://download.docker.com/linux/debian/gpg | sudo apt-key add -

on a NON-ROOT shell and I’m guessing the sudo part did not execute because of an error message.

$ sudo apt-key fingerprint 0EBFCD88
pub   rsa4096 2017-02-22 [SCEA]
  9DC8 5822 9FC7 DD38 854A  E2D8 8D81 803C 0EBF CD88
uid           [ unknown] Docker Release (CE deb) <docker@docker.com>
sub   rsa4096 2017-02-22 [S]

I have uid [ unknown] included but not found in the instruction. What is this and how can I troubleshoot this.

Thank you


(Dstudio101) #3

This is really getting on my nerves. I’m now away from the desktop. And just installed docker on a third debian desktop successfully.

apt-get update 

looks into a lot of docker related URLs. On the third successful install, apt-get update only look into one docker url. I can’t list the urls as am now away from the desktop. But this is a good way of keeping tabs on my progress.


(Dstudio101) #4

Nope, I still don’t have any solution for my issue. Can someone point me to where I can possibly get a solution to this issue?

Do I need to provide more information to help solve this issue. Please help.

Thank you,

DS101


(Dstudio101) #5

I visited this site for a solution

# dpkg -l | grep libgnutls ii libgnutls-deb0-28:amd64 3.3.8-6+deb8u7 amd64 GNU TLS library - main runtime library rc libgnutls-deb0-28:i386 3.3.8-6+deb8u7 i386 GNU TLS library - main runtime library ii libgnutls-openssl27:amd64 3.5.8-5+deb9u3 amd64 GNU TLS library - OpenSSL wrapper ii libgnutls30:amd64 3.5.8-5+deb9u3 amd64 GNU TLS library - main runtime library ii libgnutls30:i386 3.5.8-5+deb9u3 i386 GNU TLS library - main runtime library

It looks like I have two (2) versions of libgnutls when I try to remove libgnutls-deb0-28

So I try to remove one of them - the older one with some errors that prevents me from completely removing the package:

[code]# apt-get remove --purge libgnutls-deb0-28
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libcurl3-gnutls : Depends: librtmp1 (>= 2.4+20131018.git79459a2-3~) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.[/code]

Using synaptic - I looked into BROKEN packages. Resolve this issue by deleting these packages and now I don’t get error message using apt-get update for the docker repository.