Docker Community Forums

Share and learn in the Docker community.

[solved] Connecting windows eclipse with docker for windows?


(Vinayagg) #1

I am trying to connect docker tooling in eclipse with mobi based docker for windows. I am having following issues

  1. In Arun Gupta’s presentation, he mentioned that docker toolbox will automatically detect docker. Has anyone seen auto discovery to work on Windows? At least it is not working for me.

  2. When I try to search for a connection, I get error “you need to set preferences for docker machine” and it shows dialog box to set path for docker machine and VM Driver (virtual box).
    So looks like this does not yet work with “docker for windows”. Is this a correct conclusion?


(Nicolas Bihan) #2

I know this is old, but I just tested Eclipse Neon with Docker for Windows Beta 17 and was able to connect to the local daemon.
Just create a “new connection” from the Docker perspective of Eclipse Docker Tooling


Give a “Connection name” and use custom TCP connection settings http://localhost:2375
The list of available images and running containers should appear.


(Michael Friis) #3

Glad you got it working!

I had a look at the docs: https://wiki.eclipse.org/Linux_Tools_Project/Docker_Tooling/User_Guide#Edit_Connection_Wizard

I haven’t tested but on Windows, the daemon API should also be available on npipe:////./pipe/docker_engine.


(Nicolas Bihan) #4

Not too sure where I could set in Eclipse Docker Tooling npipe:////./pipe/docker_engine


(Michael Friis) #5

@nicotexas maybe in the “unix socket” field. If they don’t support the Windows npipe model, I recommend opening an issue with Eclipse.


(Nicolas Bihan) #6

Indeed they don’t support Windows npipe model. Time to open an issue to Eclipse.
Thanks!


(Keklabs) #7

I have same issue to connect from RubyMine with Docker plugin. Only HTTP protocol is supported.

I have DOCKER 1.12.0-RC4-BETA20.

Is there some way, how to enable support for http://docker.local:2375/ or HTTPs on MobbyLinux image additionaly to npipe:////./pipe/docker_engine ?

There is some recommendation on [https://msdn.microsoft.com/en-us/virtualization/windowscontainers/docker/configure_docker_daemon], but the described configuration for hosts breaks docker start.

{
    "hosts": ["tcp://0.0.0.0:2376", "npipe://"],
    "tlsverify": true,
    "tlscacert": "C:\\ProgramData\\docker\\certs.d\\ca.pem",
    "tlscert": "C:\\ProgramData\\docker\\certs.d\\server-cert.pem",
    "tlskey": "C:\\ProgramData\\docker\\certs.d\\server-key.pem",
}

(Dmarinelli) #8

Thanks for that, it was a big help, just tried with latest STS and docker for windows beta 20 and worked