Docker Community Forums

Share and learn in the Docker community.

[SOLVED] Problem mounting file inside mounted volume

beta
docker

(Rtfpessoa) #1

Expected behavior

With docker toolbox 1.9.1 I was able to mount a volume to a docker and then mount a file inside that volume.

A fix could be to move the file to the directory before mounting it, but my use case is to have multiple dockers running in the same directory using different files.

Actual behavior

I receive an error:

docker: Error response from daemon: rpc error: code = 2 desc = “oci runtime error: could not synchronise with container process: not a directory”.

Information

  • the output of:
    • pinata diagnose -u on OSX

OS X: version 10.11.4 (build: 15E65) Docker.app: version v1.11.1-beta10 Running diagnostic tests: [OK] docker-cli [OK] Moby booted [OK] driver.amd64-linux [OK] vmnetd [OK] osxfs [OK] db [OK] slirp [OK] menubar [OK] environment [OK] Docker [OK] VT-x Docker logs are being collected into /tmp/20160505-113900.tar.gz Most specific failure is: No error was detected Your unique id is: E28F0BAE-A395-404E-BA15-63D8BEB37D5B Please quote this in all correspondence.
- host distribution and version: OSX 10.11.x

Steps to reproduce the behavior

docker run -v /private/tmp/test_directory:/src:rw -v /private/tmp/my_test_file.json:/src/my_file.json:rw -it --entrypoint bash ubuntu:latest

Somehow after rebooting the computer twice it worked. No idea why.