Docker Community Forums

Share and learn in the Docker community.

[SOLVED] Problems installing Docker (Armbian/Buster)

I’m trying to install Docker on an Odroid HC2(xu4) running Armbian 20.05.7 stable.
I’m using the procedure here (specifically, the arm64 branch) and when I get to

install the latest version of Docker Engine and containerd
sudo apt-get install docker-ce docker-ce-cli containerd[dot io]

I get

Package docker-ce is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
docker-ce-cli:arm64
E: Package ‘docker-ce’ has no installation candidate
E: Unable to locate package docker-ce-cli
E: Unable to locate package containerd[dot io]
E: Couldn’t find any package by glob ‘containerd[dot io]’
E: Couldn’t find any package by regex ‘containerd[dot io]’

When I try to run
sudo apt-get install docker-ce-cli:arm64
I get

The following packages have unmet dependencies:
docker-ce-cli:arm64 : Depends: libc6:arm64 (>= 2.17) but it is not installable
E: Unable to correct problems, you have held broken packages.

I’ve tried
sudo apt install -f
apt-get update --fix-missing
dpkg --configure -a
but nothing seems to fix it. And when I do
dpkg --audit
to try to identify the problematic packages, I get no results.

NOTE: Wherever you see ‘containerd[dot io]’ above, read it as ‘containerd.io’. In order to post this, I had to change all above references to the latter because it gets treated as a link and I can’t (as a new user) include more than 2 links in a post.

Please HELP!

Sorry. Disregard. I used softy to install it and everything works fine.