SSL Certificate Error in Quickstart behind corporate firewall

Hi All,

I am having some issues with Docker Desktop, when I run the very first command in the Quick Start:

docker run --name repo alpine/git clone

I receive an SSL error:

fatal: unable to access '': SSL certificate problem: unable to get local issuer certificate

This is a common occurrence because I work behind a corporate firewall, but I’m confused how I should go about resolving it this time. If I create a new PowerShell, stick all of the git config keys from Docker Desktop’s git config into an empty repo in that PowerShell, then try to clone GitHub - docker/getting-started: Getting started with Docker, it works fine. I’ve also found that all repos fail to pull in Docker Desktop with the same error, not just the Quick Start repo.

What should I change to allow Docker Desktop to pull repos?

did you ever solve this?


this can be solved by installing your corporate CA certs to the image below

add the below lines before you are trying to access the internet from the container

FROM alpine:latest

COPY my-cert.pem /usr/local/share/ca-certificates/my-cert.crt

RUN cat /usr/local/share/ca-certificates/my-cert.crt >> /etc/ssl/certs/ca-certificates.crt

# apk update and add or any internet access.