Docker Community Forums

Share and learn in the Docker community.

Startup error using clustering in AWS


(Tomwaterhouse) #1

I am trying to deploy a Swarm manually in EC2 using Consul as the keystore.
Here is my Consul startup:
sudo docker daemon -H tcp://0.0.0.0:2375 -H unix:///var/run/docker.sock &
sudo docker -H tcp://172.31.2.154:2375 run -d -p 8500:8500 -h consul progrium/consul -server -bootstrap

I am using the following to start a docker daemon on the Swarm master. I am running in EC2 with Ubuntu 14.04 with an upgraded kernel to 3.19.

Any help would be appreciated.

sudo docker daemon --cluster-store=consul:///172.31.2.154:8500 --cluster-advertise=eth0:2375 -H tcp://0.0.0.0:2375 -H unix:///var/run/docker.sock &

I am getting the following error on startup of the master daemon:
INFO[0000] [graphdriver] using prior storage driver "aufs" INFO[0000] Initializing discovery without TLS INFO[0000] API listen on [::]:2375 INFO[0000] API listen on /var/run/docker.sock ERRO[0000] discovery error: Unexpected watch error ERRO[0000] Registering as "172.31.2.172:2375" in discovery failed: cannot set or renew session for ttl, unable to operate on sessions INFO[0000] Firewalld running: false INFO[0000] Default bridge (docker0) is assigned with an IP address 172.17.0.1/16. Daemon option --bip can be used to set a preferred IP address WARN[0000] Your kernel does not support swap memory limit. INFO[0000] Loading containers: start. ............ INFO[0000] Loading containers: done. INFO[0000] Daemon has completed initialization INFO[0000] Docker daemon commit=a34a1d5 execdriver=native-0.2 graphdriver=aufs version=1.9.1


(Auzias) #2

Hi!

I also have this error:

I run consul with:

/usr/bin/docker daemon -H tcp://0.0.0.0:2375 -H unix:///var/run/docker.sock --cluster-advertise eth0:2375 --cluster-store consul://127.0.0.1:8500

Have you found any details or reason or solution about that ?
Note that I do not use AWS


(Tomwaterhouse) #3

I retried the same with Ubuntu Vivid (15.04) to get the correct Linux
kernel version and still run into the same error.


(Russell Jurney) #4

I get this same error. I am pretty bummed out nobody ever responded to this thread. I am stuck! :frowning: