Docker Community Forums

Share and learn in the Docker community.

"Strange Things" behind docker build command


(Javier Ramirez) #1

Hi all,
I have reproduce a problem that one of my team mates had some time ago. He received an error when building an image from one of my Dockerfiles… We can’t see anything wrong, but he can’t create that image, he always receive a file not found on aufs filesystem when copying one of the files required for that image… It was an X-Files error… but today (after a couple of months) I have the same error when building “dockercoins” example (preparing a class)…

dockercoins/worker$ docker build -t worker .
Sending build context to Docker daemon 4.608 kB
Step 1 : FROM python:alpine
—> 2ed4f02ea8d4
Step 2 : RUN pip install redis
—> Using cache
—> 782aee514fd5
Step 3 : RUN pip install requests
—> Using cache
—> c8682b3afce9
Step 4 : COPY worker.py /
open /var/lib/docker/aufs/layers/3f4d3ecffd4770e9b4ec8df1732483a32993368893e33f19efd5c816bca87570: no such file or directory

Of course I can build image in any other system … Server has disk space and I can’t find any error in any log …
Dockerfile is quite simple…

FROM python:alpine
RUN pip install redis
RUN pip install requests
COPY worker.py /
CMD [“python”, “worker.py”]

Even if I change “COPY worker.py /” to a specific file in root … “COPY worker.py /worker.py”, I get same error…
But if I change destination dir, it works… I have checked container’s root file-system permissions but they are right… and it builds in any other system I have tried… and of course… same docker version in all tries…

Debugging info …
DEBU[0010] Calling POST /v1.24/build?buildargs=%7B%7D&cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=Dockerfile&labels=%7B%7D&memory=0&memswap=0&rm=1&shmsize=0&t=worker&ulimits=null
DEBU[0010] [BUILDER] Use cached version: [/bin/sh -c pip install redis]
DEBU[0010] [BUILDER] Use cached version: [/bin/sh -c pip install requests]
DEBU[0010] [BUILDER] Cache miss: [/bin/sh -c #(nop) COPY file:3c29379b0d985e7631a478453e0f831599595e5827f96a558599cb6609eaa9c7 in / ]

Many Thanks In Advance and Regards,
Javier R.


Current recommendations for storage backend
(Javier Ramirez) #2

I can not reproduce the problem because I have reinstalled docker and before that I had to remove all /var/lib/docker because problem persists after first reinstall (without removing old lib docker files…).

Strange behavior … If I get same error again I will notice you.
Thanls,
Javier R.


(Javier Ramirez) #3

Hi I have received an email about an automated build that is having same issue…
rchive: /CONSUL/consul_web_ui.zip
inflating: index.html
creating: static/
inflating: static/application.min.js
inflating: static/base.css
inflating: static/base.css.map
inflating: static/bootstrap.min.css
inflating: static/consul-logo.png
inflating: static/favicon.png
inflating: static/loading-cylon-purple.svg
Archive: /CONSUL/consul.zip
inflating: consul
—> 6bce6ba85350
Removing intermediate container ec68c8c1ca58
Step 8 : VOLUME /CONSUL
—> Running in e022a4cfc60d
—> 776a30a39a01
Removing intermediate container e022a4cfc60d
Step 9 : COPY entrypoint.sh /entrypoint.sh
Removing intermediate container a311a421187f
stat /var/lib/docker/overlay/b32056c2eed4204c4c514a8dd9e0e8f530b57786989d7611e798c1c84d49b7a9/merged/entrypoint.sh: no such file or directory

Entrypoint script is in my code directory and when I build the same image local I haven’t any problem!!!

Many Thanks,
Javier R.