Docker Community Forums

Share and learn in the Docker community.

Sttings for using https alpine mirror

I’m behind a corporate firewall and I got the proxy etc setup. But when I run ‘docker build’ from the quick start guide, I got the following error:

Step 13/21 : RUN rm -rf node_modules &&     apk add zip &&     zip -r /app.zip /app
 ---> Running in 4771861451d6
fetch http://dl-cdn.alpinelinux.org/alpine/v3.11/main/x86_64/APKINDEX.tar.gz
ERROR: http://dl-cdn.alpinelinux.org/alpine/v3.11/main: Permission denied
WARNING: Ignoring APKINDEX.70f61090.tar.gz: No such file or directory
fetch http://dl-cdn.alpinelinux.org/alpine/v3.11/community/x86_64/APKINDEX.tar.gz
ERROR: http://dl-cdn.alpinelinux.org/alpine/v3.11/community: Permission denied
WARNING: Ignoring APKINDEX.ca2fea5b.tar.gz: No such file or directory
ERROR: unsatisfiable constraints:
  zip (missing):
    required by: world[zip]
The command '/bin/sh -c rm -rf node_modules &&     apk add zip &&     zip -r /app.zip /app' returned a non-zero code: 1

I tried from my same cygwin console that wget https://dl-cdn.alpinelinux.org/alpine/v3.11/main/x86_64/APKINDEX.tar.gz works while wget http://dl-cdn.alpinelinux.org/alpine/v3.11/main/x86_64/APKINDEX.tar.gz doesn’t. Is there any settings I can change to make it pointing to https mirror?

I tried to add the https link to “registry-mirrors” under docker settings but doesn’t seem to work