Docker Community Forums

Share and learn in the Docker community.

Stuck behind a corporate proxy, cannot get a docker setup to complete

Port # wouldn’t matter would it? We don’t use 80 or 443 for http or https proxy. Oh and to answer the other question from earlier I’m using CentOS 7.6.

Does systemctl status -l docker show http-proxy is being picked up?

OS - Mac OSX Mojave 10.14.6
Docker version 18.09.2, build 6247962
Docker for Mac: Version 2.0.0.3 (31259)

I’m in the same boat. At this point, I’m simply just trying to get an image to pull down. I’ve tried everything. Nothing works, I’ve tried putting the HTTP(S)_PROXY settings everywhere imaginable… nothing. works. I’ve even tried putting the proxies into the Desktop config manually… no dice. How is it 2020 and this is still an issue? I’ve come across so many threads - dating back to '16! - where people are having this issue.
I’ve followed the link back at the top of this thread, and the related link in the documentation… none of it has made a difference.

I’m trying to setup a process for other developers to follow after me so that they can do development for our system. Part of that process involves grabbing a docker image with a database in it, and spinning it up so they can connect to it. That’s all I need. Nothing fancy. But I can’t even get a simple docker image pull to work. I get “Proxy Authentication Required” I don’t have this problem with Maven. Only Docker. I’m using SSH to tunnel into the network, the local machine is then setup as the proxy using 127.0.0.1:port. I’ve read that Docker run its own VM so using 127.0.0.1 as the proxy isn’t going to work. But I can’t change the setup, only follow what was setup before me. I can pull mags from public repos, just not our private one behind the proxy.
I’m just about had it to the point where I’m ready to toss Docker under the bus and back it (the bus) a few times.

You might have better success starting a new thread to ask for help. It seems like you specifically could look in the Mac discussions forums. Proxies are finicky things and aren’t always configured the same, so this issue is more likely multiple configuration issues for different situations. And if you’re able to do a docker pull from a public repo and not your own, it does sound like your proxy setup is the frustrating part (I also hate on proxies). That said, I don’t use Mac and I don’t have to fight with a proxy and I haven’t used Maven, but maybe I can offer some generic help.

Docker is an application that runs in the OS of the machine. I don’t think it’s correct to say Docker runs its own VM although the concept of a container is similar to a VM. 127.0.0.1 from the host is the host’s localhost address; 127.0.0.1 from the container is the container’s localhost address. I don’t beleive you want to use localhost as part of your proxy configuration unless the proxy services are indeed running from the host. If the proxy is in fact running on the host, then you might be able to use 127.0.0.1 but since that’s not working you might want to try using its actual IP to see if that behaves any differently. Otherwise, doublecheck the proxy settings, and if it says authentication is required perhaps you have some credentials you could try passing to the proxy? You know your environment better than I.