Docker Community Forums

Share and learn in the Docker community.

My Docker Proxy Settings Aren't Taking - Help!

Hello Docker Gurus,

I’m Docker newbie, and I need help with the proxy settings on a new Docker install.

So I just built a new server with a fresh install of Ubuntu 20.04 LTS. Using apt-get, I then installed Docker version 19.03.8. My office uses an HTTP and HTTPS proxy, so I have to configure Docker to work with those servers. Walking through this documentation [[https://docs.docker.com/config/daemon/systemd/]], I did the following:

me@ubuntu1:/home$

me@ubuntu1:/home$ sudo mkdir -p /etc/systemd/system/docker.service.d

me@ubuntu1:/home$ sudo vi /etc/systemd/system/docker.service.d/http-proxy.conf

me@ubuntu1:/home$

me@ubuntu1:/home$

me@ubuntu1:/home$ more /etc/systemd/system/docker.service.d/http-proxy.conf

[Service]

Environment="http://10.10.10.101:1234"

Environment="https://10.10.10.101:1234"

me@ubuntu1:/home$

Then I flushed the changes and restarted Docker:

me@ubuntu1:/home$ sudo systemctl daemon-reload

me@ubuntu1:/home$ sudo systemctl restart docker

me@ubuntu1:/home$

But:

me@ubuntu1:/home$

me@ubuntu1:/home$ sudo systemctl show --property=Environment docker

Environment=

me@ubuntu1:/home$

me@ubuntu1:/home$

So, the proxy settings I’m configuring are being ignored by Docker. Why might that be the case? Can anyone see what I’m doing wrong? Thank you.