Swarm 1.12 IPVS Load Balance with Persistency Connection

Due to Swarm mode on docker 1.12.0 will use IPVS load balance on linux kernel for distribute traffic to all container in service. Anyway as test in my lab test with load balance “wordpress” service. I found the problem about persistency connection on this feature. Because IPVS will load balance to all possible container without considerate existing connection of client. So when i’m login wordpress in time “T1” and submit. On “T2” time the session may or may not balance to same container that service my screen on “T1” time. That make it redirect login page again after refresh connection. Normally of IPVS we can set option “-p” for keep persistence connection for load balance from client to make sure that client was reroute to same server that it used to touch. Just queries that how can we config this option with swarm mode 1.12. Please kindly suggest


I’m with this problem too, if you found a solution please post here!

u could install a memcached service to distribute php session between nodes

something like this https://www.digitalocean.com/community/tutorials/how-to-share-php-sessions-on-multiple-memcached-servers-on-ubuntu-14-04