Swarm status stuck as pending - can't leave or create new one

I’m running Docker 1.12.3 on Windows 10 and created a manager swarm and 2 worker Hyper-V VM’s going through some tutorials. On my machine (not a VM) I joined the swarm as another manager. After I was done with the tutorials I left the swarm on my machine and it seemed like it worked. I then deleted the docker machine VM’s and tried docker swarm init but got node is already part of swarm. Then I tried docker swarm leave --force and got context deadline exceeded. I also tried docker swarm init --force-new-cluster and same error context deadline exceeded.

Searches haven’t given much info on things to try so I decided to uninstall Docker, reboot, then reinstall. I still get the same error and docker info shows my swarm status as pending. I also have all my previous images.

Containers: 1
 Running: 0
 Paused: 0
 Stopped: 1
Images: 8
Server Version: 1.12.3
Storage Driver: aufs
 Root Dir: /var/lib/docker/aufs
 Backing Filesystem: extfs
 Dirs: 18
 Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
 Volume: local
 Network: null overlay bridge host
Swarm: pending
 NodeID: bd1v4un37imgptrj1dxfh7sqz
 Is Manager: false
 Node Address:
Runtimes: runc
Default Runtime: runc
Security Options: seccomp
Kernel Version: 4.4.27-moby
Operating System: Alpine Linux v3.4
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.919 GiB
Name: moby
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): true
 File Descriptors: 13
 Goroutines: 41
 System Time: 2016-11-30T17:04:53.0006032Z
 EventsListeners: 0
Registry: https://index.docker.io/v1/
Insecure Registries:

Any ideas on how to get rid of the swarm? Should I uninstall Docker and delete the MobyLinux VM, then reinstall? I don’t want to totally mess things up so I can’t install Docker at all.

i’m kind of having the same issue with my swarm mode
i have 2 managers in 2 defferents machines
one of them has swarm:active and the other has swarm pending
but i can’t create any services in any of the both machines
any help?

i faced same error (but using on ubuntu). I first deleted all nodes (including manager which was before) and executed docker swarm init --force-new-cluster
It helped me to restore the swarm.
now need to create again the nodes.

In my experience you should just stop docker desktop at all when using swarm. I literaly spent months trying to get docker desktop working in a swarm with no success.
You will constantly hit a wall and at some point there won’t be a solution and you will be stuck.

In my case I got hard stuck at the overlay network. I was unable to communicate from windows to a linux (and the other way around). All containers could join the overlay network but the packages just didn’t reach its destination.

If you manage to get this working, I would like to know how you did it.