Docker Community Forums

Share and learn in the Docker community.

Synology docker redmine


(Djo074270) #1

Dear all.
New user of redmine thru docker on a synology, I’m stuck with the setting up of emailing.
I found quite a lot of help on the web but…

To find the directory:

sudo docker exec -ti synology_redmine /bin/bash
cd config
And I find the configuration.yml

I modified it in accordance (I hope so) to YAML file. [https://www.json2yaml.com/]
Removing comments lines below, what I obtained: (indentation seems not to be take into account in this window…)


default:
attachments_storage_path: /home/redmine/data/files

Configuration of the autologin cookie.

autologin_cookie_name: autologin
autologin_cookie_path: /
autologin_cookie_secure: false

Configuration of SCM executable command.

scm_subversion_command: svn
scm_mercurial_command: hg
scm_git_command: git
scm_cvs_command: cvs
scm_bazaar_command: bzr
scm_darcs_command: darcs
scm_stderr_log_file: /var/log/redmine/redmine/redmine_scm_stderr.log
mirror_plugins_assets_on_startup: true
sudo_mode: false
sudo_mode_timeout: 15
imagemagick_convert_command: /usr/bin/convert
max_concurrent_ajax_uploads: 2
openid_authentication_store: :memory

Path to store backups (docker-redmine only)

backup_storage_path: /home/redmine/data/backups
backup_expiry: 0

specific configuration options for production environment

that overrides the default ones

production:
email_delivery:
smtp_settings:
domain: “smtp.gmail/dot/com”
password: “yyyyyyyyyyy”
enable_starttls_auto: true
address: smtp.gmail/dot/com
user_name: “xxxx.xxxx@gmail/dot/com”
authentication: :plain
port: 465
delivery_method: :smtp

specific configuration options for development environment

that overrides the default ones

development:

you need to set a font installed in your server.


And if convert it to json:


{
“default”: {
“attachments_storage_path”: “/home/redmine/data/files”,
“autologin_cookie_name”: “autologin”,
“autologin_cookie_path”: “/”,
“autologin_cookie_secure”: false,
“scm_subversion_command”: “svn”,
“scm_mercurial_command”: “hg”,
“scm_git_command”: “git”,
“scm_cvs_command”: “cvs”,
“scm_bazaar_command”: “bzr”,
“scm_darcs_command”: “darcs”,
“scm_stderr_log_file”: “/var/log/redmine/redmine/redmine_scm_stderr.log”,
“mirror_plugins_assets_on_startup”: true,
“sudo_mode”: false,
“sudo_mode_timeout”: 15,
“imagemagick_convert_command”: “/usr/bin/convert”,
“max_concurrent_ajax_uploads”: 2,
“openid_authentication_store”: “memory”,
“backup_storage_path”: “/home/redmine/data/backups”,
“backup_expiry”: 0
},
“production”: {
“email_delivery”: {
“smtp_settings”: {
“domain”: “smtp.gmail/dot/com”,
“password”: “yyyyyyyyyyy”,
“enable_starttls_auto”: true,
“address”: “smtp.gmail/dot/com”,
“user_name”: “xxxx.xxxx@gmail/dot/com”,
“authentication”: “plain”,
“port”: 465
},
“delivery_method”: “smtp”
}
},
“development”: null
}


It seems to be ok. But when I restart, each time, this file is systematicaly replaced by the original one.
I deduce that I’m wrong, but I don’t know where…

Thanks for your help.
Djo


(Djo074270) #2

Dear All,

Little UP,
Any idea?

Thanks a lot!

Djo