Docker Community Forums

Share and learn in the Docker community.

Time difference in microsoft/dotnet-framework


(Hexabitag) #1

Hello,

When running a container based on microsoft/dotnet-framework there is a time difference between the docker host and the container itself.

I have tried to enable and run w32time service in the container but I always get an error that the service cannot start.

C:\Luna\Server>sc config w32time start=auto
[SC] ChangeServiceConfig SUCCESS

C:\Luna\Server>net start w32time
The Windows Time service is starting.
The Windows Time service could not be started.

A system error has occurred.

System error 5 has occurred.

Access is denied..

I am running Docker for Windows (Windows containers) in a Windows-10-Pro-64 bit OS.

If I run a container based on microsoft/windowsservercore:latest there is no time difference at all.

Any ideas?

Thanks .


(Kamukag3e999) #2

I have exactly the same problem. LTSC images work (e.g., 4.7.2-runtime-20180615-windowsservercore-ltsc2016), but those cut ones don’t. I’ve created some tickets:


https://social.msdn.microsoft.com/Forums/en-US/e5cd78f1-2f71-47b2-99a5-c3aca8d57b26/unable-to-run-windows-time-service-within-a-docker-container?forum=windowscontainers
but still no answer. LTSC is 3 times bigger unfortunately.


(Duke64) #3

Hey folks,
today I run into the same trap. Do you have a solution ready by now?

Thanks and Greetings


(Kamukag3e999) #4

Unfortunately, Microsoft did not resolve the problem yet.