Docker Community Forums

Share and learn in the Docker community.

Timeout on HTTP queries over IPv6

swarm

(Mic Szillat) #1

Hi folks,

I’m currently working on a setup where I use Traefik as an ingress webserver. It works well when I start a single instance on my development machine. But when I deploy it as a stack in my (single-node) swarm setup, I run into an issue with IPv6.

HTTP requests that come over IPv4 are served fine, but IPv6 time out. This does only happen in a stack deployment, not with docker run or similar.

Here is my compose file:

---
version: "3.3"
services:
  traefik:
    image: traefik
    ports:
      - 80:80

Deployed with:

docker stack deploy --compose-file docker-compose.yml ingress

Tested with curl http://localhost -4 vs. curl http://localhost -6

Version: Docker 18.02.0-ce
Operating System: CentOS 7, Arch, CoreOS

This seems to be an issue with Docker’s layer 3 proxy. From my view, IPv6 inside the Docker network is not necessary. I even tried that by configuring Docker to allocate an IPv6 prefix on its network, but to that did not help either.

Has anyone an idea?


(Aquilapp) #2

Hello Nomaster,

Hope you are good ! :slight_smile:

I contact you cause nobody answer to your post and I encounter the same problem as your.

Do you find some solutions to resolve this IPV6 problem with traefik ?

Thanks in advance,
Arnaud


(Mic Szillat) #3

I’m sorry but I didn’t find a solution.

Currently looking into other solutions like an external TCP Proxy.

It’s really frustrating that networking, IPv6 in particular is an underrepresented topic. So I’m glad that at least you are caring. Cheers!


(Aquilapp) #4

Yes, there is few topics about that…

I currently look too for a proxy with HAPROXY with IPV6 revert to IPV4 (Traefik port redirect in my HAProxy Backend configuration) but it didn’t work at the moment.

Arnaud