Docker Community Forums

Share and learn in the Docker community.

TLS Handshake Error on Mac OSX

docker

(Adityaglobo) #1

Hi,

I am relatively new to Docker and am having problems setting up my containers. I believe its a problem with my docker-machine not being able to connect to the internet and so everytime I run my docker-compose, I get a TLS handshake error. I have deleted docker and all its binaries and reinstalled it. Same with virtualbox and reset my local Mac network settings to default as well. But the problem still seems to persist.

This problem only began about 2 weeks ago and had worked perfectly fine before that. I did not change anything on the networking side, atleast not intentionally.

How may I go about debugging a TLS handshake error when downloading images? Thanks in advance for your help.

I have added my docker info and diagnostic ID below.

Diagnostic ID: C1BCF074-5D58-4AA6-BB6B-964E8EC9F845

Docker Info:
Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 0
Server Version: 18.05.0-ce
Storage Driver: aufs
Root Dir: /mnt/sda1/var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 0
Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 773c489c9c1b21a6d78b5c538cd395416ec50f88
runc version: 4fc53a81fb7c994640722ac585fa9ca548971871
init version: 949e6fa
Security Options:
seccomp
Profile: default
Kernel Version: 4.9.93-boot2docker
Operating System: Boot2Docker 18.05.0-ce (TCL 8.2.1); HEAD : b5d6989 - Thu May 10 16:35:28 UTC 2018
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 3.858GiB
Name: default
ID: J6ZB:4N5T:D5PC:QOZK:FJBQ:LH25:ALPT:BE6T:YBPW:BLTD:W7SN:LZZF
Docker Root Dir: /mnt/sda1/var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Labels:
provider=virtualbox
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false