TortoiseSVN can't connect to host

I created an svn server on my OpenMediaVault nas system.

First I ran the following command:

docker pull garethflowers/svn-server


docker run \
    --name serversvn \
    --detach \
    --volume /home/svn:/var/opt/svn \
    --publish 3690:3690 \

So I have been following the developer’s instructions.

Now I started the container.The value “STATE” is “running” and the value “STATUS” is “Up 5 minutes (healthy)”.

then I ran the command:

docker exec -it serversvn svnadmin create vbrepo

I tried to access the repository but TortoiseSVN can’t find the host svn://serversvn/vbrepo

What makes you think svn://serversvn/vbrepo would be known and accessible outside your container? You need to access it using svn://{your host name or ip}:3690/vbrepo.

1 Like

still doesn’t work:

My host name is my nas ip or my computer ip?

{your host name or ip} = the docker host

1 Like

where can I find the ip of docker? perhaps coincides with the ip of the nas?

Wherever the Docker Engine is running on.

1 Like