Ubuntu docker engine build proxy problem

Hey guys, im new with Docker.

I try to build a example image, and get problems with my proxy.

my dockerfile:

FROM microsoft/nanoserver
COPY testfile.txt c:\\
RUN dir c:\

When i try docker run with a image, which is not localy available all works, docker download the image from hub.

i tried the following settings:


 "proxies": {
   "default": {
     "httpProxy": "",
     "httpsProxy": ""



i also tried with arguments:

sudo docker build --build-arg HTTP_PROXY="" --build-arg HTTPS_PROXY="" -t tutorial-docker .

i always get this error:

ERROR: failed to solve: microsoft/nanoserver: failed to resolve source metadata for docker.io/microsoft/nanoserver:latest: failed to authorize: failed to fetch anonymous token: Get "https://auth.docker.io/token?scope=repository%3Amicrosoft%2Fnanoserver%3Apull&service=registry.docker.io": dial tcp connect: no route to host

Any ideas what i doing wrong?

I don’t understand it. You are using a Windows container image, but created the topic in Docker Engine, yet you refer to files on a Linux filesystem.

So which Docker you have on which platform?