Docker Community Forums

Share and learn in the Docker community.

Ubuntu package for docker-engine 1.11.1 not signed?


(Jay Berkenbilt) #1

On Ubuntu 16.04, after running apt-key adv --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D and creating /etc/apt/sources.list.d/docker.list:

# apt install docker-engine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  docker-engine
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/14.5 MB of archives.
After this operation, 73.4 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  docker-engine
Install these packages without verification? [y/N] 

This was working earlier today prior to the release of 1.11.1. I’m trying to determine whether this is operator error or a problem with the package file. If I am able to make a conclusive determination, I will post a follow-up.


(Jay Berkenbilt) #2

I think never mind. I ran into this running ansible to install docker-engine on a new system. Then I ran it a few minutes later with no modifications on a different system and didn’t see the problem. I must be running into some transient issue on one system. Sorry for the noise. I don’t know why I am seeing it on one system and not on another when both systems were launched the same way with the same playbooks starting from the same AMI in ec2.


(Zabzal) #3

I am currently seeing this issue. I am using vagrant shell provisioning to run

sudo curl -sSL “https://get.docker.com/” | sh

Up unit yesterday 5/6/16, I was able to provision my Ubuntu Trusty VM using this script. As of yesterday, I am getting

WARNING: The following packages cannot be authenticated!
docker-engine
E: There are problems and -y was used without --force-yes

Any ideas what the issue might be?