Ulimits over docker stack deploy doesn't work

Let me describe my case
I’ve created by

docker stack deploy

for Elasticsearch service and observed that ulimits parameter didn’t update as expected.

my enviroment:

[root@hostname etc]# docker version
Client: Docker Engine - Community
 Version:           20.10.12
 API version:       1.40
 Go version:        go1.16.12
 Git commit:        e91ed57
 Built:             Mon Dec 13 11:45:41 2021
 OS/Arch:           linux/amd64
 Context:           default
 Experimental:      true

Server: Docker Engine - Community
  Version:          19.03.2
  API version:      1.40 (minimum version 1.12)
  Go version:       go1.12.8
  Git commit:       6a30dfc
  Built:            Thu Aug 29 05:27:34 2019
  OS/Arch:          linux/amd64
  Experimental:     false
  Version:          1.4.13
  GitCommit:        9cc61520f4cd876b86e77edfeb88fbcd536d1f9d
  Version:          1.0.3
  GitCommit:        v1.0.3-0-gf46b6ba
  Version:          0.18.0
  GitCommit:        fec3683
version: "3.7"

    container_name: es_coordination_1
    image: af2.corpo.t-mobile.pl/elk-docker/elasticsearch/elasticsearch:7.16.1
    user: elasticsearch
      - node.name=es_coordination_1
      - xpack.ml.enabled=false
      - xpack.security.enabled=true
      - xpack.security.http.ssl.enabled=true

        soft: -1
        hard: -1
        soft: 65535
        hard: 65535

at least I saw in docker container that I have

elasticsearch@441ecdf403aa:~$ ulimit -a
core file size          (blocks, -c) unlimited
data seg size           (kbytes, -d) unlimited
scheduling priority             (-e) 0
file size               (blocks, -f) unlimited
pending signals                 (-i) 1029415
max locked memory       (kbytes, -l) 64
max memory size         (kbytes, -m) unlimited
open files                      (-n) 1048576
pipe size            (512 bytes, -p) 8
POSIX message queues     (bytes, -q) 819200
real-time priority              (-r) 0
stack size              (kbytes, -s) 8192
cpu time               (seconds, -t) unlimited
max user processes              (-u) unlimited
virtual memory          (kbytes, -v) unlimited
file locks                      (-x) unlimited

from elaticsearch point of view it’s also doesn’t look as expected:

"wOMZvpx7QkW1IoDB9-hv5A" : {
      "timestamp" : 1647361899514,
      "name" : "es_coordination_1",
      "transport_address" : "",
      "host" : "",
      "ip" : "",
      "roles" : [
      "attributes" : {
        "xpack.installed" : "true",
        "transform.node" : "true"
      "process" : {
        "timestamp" : 1647361899516,
        "open_file_descriptors" : 1771,
        "max_file_descriptors" : 1048576,

on the system I’ve also:
config in /etc/security/limits.conf

elasticsearch soft nofile 65535
elasticsearch hard nofile 65535
elasticsearch soft memlock unlimited
elasticsearch hard memlock unlimited

oh now I’ve found the fix case