Unable to access dockerhub from proxy behind corporate

Hello ,

I am a beginner with docker .I am running docker 1.12 on Fedora25 machine on a corporate network. Per docs.docker.com , I have created a http_proxy file in /etc/systemd/syste/docker.service.d and provided the proxy details as mentioned. But when I try to access docker hub to pull hello-world image or any image, I am getting the below error.

Unable to find image ‘hello-world:latest’ locally
_Trying to pull repository docker.io/library/hello-world … _
/usr/bin/docker-current: Get https://auth.docker.io/token?scope=repository%3Alibrary%2Fhello-world%3Apull&service=registry.docker.io: dial tcp: lookup auth.docker.io on [::1]:53: read udp [::1]:39175->[::1]:53: read: connection refused.
See ‘/usr/bin/docker-current run --help’.

Are there any specific setup for Fedora ? I tried googling but could get mostly for ubuntu, centos but very few info w.r.t. Fedora.

Could I get some assistance in resolving this error ? I had spent close to 4 hours researching without any luck. Any help would be greatly appreciated!

export http_proxy=http://username:userpasswd@proxy.address:port
export https_proxy=https://username:userpasswd@proxy.address:port

In my case this works.

@mauromussin I tried this way but still getting the error :disappointed:

Are you sure that your machine is connected?
Can you update docker to the latest version?
If, despite this, you’ll get always this error I’ll give up…

@mauromussin I am trying to get the latest version of docker . Will let you know if the issue persists in the latest version as well

@mauromussin Fortunately, my issue got resolved after installing docker v1.13 on the machine :slight_smile: thanks much!