Docker Community Forums

Share and learn in the Docker community.

Unable to Drag Memory Slider in Settings [SOLVED]

solved

(Sheldon Kwok) #1

Expected behavior

Slider should slide and increase/decrease memory.

Actual behavior

Slider is locked.
pinata set hypervisor native memory=4 ncpu=4
does not change memory either.

Information

OS X: version 10.10.5 (build: 14F1713)
Docker.app: version v1.10.3-beta5
Running diagnostic tests:
[OK] docker-cli
[OK] Moby booted
[OK] driver.amd64-linux
[OK] vmnetd
[OK] lofs
[OK] osxfs
[OK] db
[OK] slirp
[OK] menubar
[OK] environment
[OK] Docker
[OK] VT-x
Docker logs are being collected into /tmp/20160330-114727.tar.gz.
Your unique id in bugsnag is: 8F0023E1-EB57-4337-81BB-F4432246BE43

Steps to reproduce the behavior

  1. Try dragging memory slider in docker menu bar

(Frenchben) #2

That’s the expected behavior - Currently the memory cannot be set via the app.

Thanks for your feedback!


(Sheldon Kwok) #3

Is using pinata supposed to work?


(Frenchben) #4

The command line will allow you to set a few things, but don’t expect it to always work. It’s more of a diagnostic tool.


(Christopher Rutter) #5

I also ran into this issue, this is a blocker for me using “Docker for Mac”. I need at least 4GB (of my 16GB MBP) for all the containers I am running.

Are there any work-arounds?


(David Sheets) #6

Running

pinata set hypervisor native memory=4

will change the configuration and immediately restart the application (and take down all running containers). You can check what configuration is in use with pinata list where it will list hypervisor = native (memory=4, ncpu=4) or similar. GUI-based configuration will be available soon.


(Christopher Rutter) #7

Thanks @dsheets, that did the trick.


(Bean5) #8

I noticed that the UI slider doesn’t reflect the setting’s value. Is that currently expected? I ran the following, then restarted app. The UI continues to say “2.0 GB” but the CLI shows 4.

pinata set hypervisor native memory=4 ncpu=8

I know that above it says we shouldn’t expect to be able to set it via the app, but have the app show the actual value is still unknown.


(David Sheets) #9

The slider is totally disconnected from the setting in Beta 8. The forthcoming Beta 9 (in 12-48 hours) should address this issue.

Thanks for your report!


(Bean5) #10

It is working in beta-10.