Docker Community Forums

Share and learn in the Docker community.

Unable to find proper tutorials for Drupal Installation

Hello Gentlemen,

Its been more than couple of weeks since I have started trying my hands on with installing Drupal, Wordpress and other CMS on my machine for local development. Since, I’m new its getting difficult for me to find a proper tutorial to follow since every tutorial has different ways and the tutorials aren’t clear. I tried those tutorials as well but ended up with error.

Any help would highly be appreciated.

Hi

There is an example of wordpress with docker-compose here Docker Hub

In the tutorials, what problemes are you seeing?

After doing all the setup as per the docker hub tutorials, I would use the I.P address provided by my terminal to access the site installation. When I do so my browser says Site Can be reached after loading for several minutes.

If you are running it on your windows pc, you should be able to access it via: http://localhost (maybe with :port) if it dosnt default to port 80

I tried doing that toom and browser said cant reach the site. However, could you please advise me whether I would need to run a mysql db container and drupal container inorder to let the whole thing work.

I followed this tutorial Install Drupal with Docker Compose | Linode to build my Drupal project. I had created a docker compose file and executed docker-compose up -d command. Below are screenshot of the error I get.

it depends on the image, i belive wordpress has a setup guide, where you need to define a database and then it will tell you if it cant reach the database.

So it should work, the error you have shown in the screenshot, you sure it mounts correctly? If you do an “ls -l” is docker-compose.yml there?

I followed the tutorial from the docker hub as well. I will do it again to show you that Im still facing issue.

here is a screen shot showing that docker detecting the docker-compose.yml file

Well, somehow managed to create a docker-compose.yml file and the command was successfully executed. I now have a running drupal site successfully. Further, I had been trying to find the source code to my drupal site on my system. Where could these files be stored any idea?

Hi

In your screenshot, the file name is “docker-compose.yml.txt”, you need to remove the .txt part.

Regarding your source code issue, by default, if you dont map any folders/volumes into the container, the source code only is present in the container itself.

i dont know what drupal image you’re using, if its the offcial one:
https://hub.docker.com/_/drupal

check the part named “volumes”

Yeah, I fixed the .txt part and it worked for me. Now I’m supposed to learn about creating volumes. Thanks for the time and help.