Unable to get Kubernetes running using Docker Desktop on Mac M1 Max

Hey, has anyone come across this problem before? When I boot Docker Desktop on my M1 Mac, Kubernetes never starts.

The two failing pods are kube-apiserver and kube-controller-manager. I’ve tried googling for the errors that they throw, but it appears nobody else has this issue.

The error screenshots are

and …

Please don’t share everything as screenshot. We can’t copy the error to search for it and we can’t quote a part to show you which part is relevant and other users would not be able to find it by searching for the error message.

You can copy the error message from Docker Desktop by clicking on the icon next to the magnifier icon. And insert the logs here:

Recently I had a problem with Kubernetes in Docker Desktop when I enabled the Beta feature to use containerd for storing images. I haven’t checked the error messages just disabled the feature, stopped Docker Desktop and started it again. (I had v4.16.2, you have a newer version)

@rimelek Great advice, will follow in the future.

I managed to solve it - I don’t know exactly what solved it but here is a couple of things I tried that shook the tree enough to make it run.

  1. Disable Kubernetes on Docker Desktop, then re-enable it.
  2. Add more RAM, storage and CPU to docker-desktop (it was already super oversized, however).
  3. Disable and re-enable Rosetta for M1 ships.