Docker Community Forums

Share and learn in the Docker community.

Unable to reconcile state of Kubernetes addons component

I had to download docker ucp 3.0.7 and upgrade to 3.1.2 . 3.1.2, 3.1.1, 3.1.0 never worked BUT my node has been down the whole time.
The message is
Message

Calico-node pod is unhealthy: calico-node pod is in phase Pending, unexpected calico-node pod condition Ready:False, calico-node pod container calico-node is not running with state {&ContainerStateWaiting{Reason:CreateContainerConfigError,Message:host IP unknown; known addresses: ,} nil nil}

1 Like

This is a most frustrating of problems because it’s work-stopping, appears to have no common cause (for me, setting cloud-provider flag caused this issue. Running without was fine on every version) and there doesn’t seem to be a reliable workaround.

Ok I think I figured out the problem…

If you are behind a proxy, use the Nodes private IP address for your UCP Node Address.

I was using the floating IP Address and it messed up with our proxy.

Just don’t specify the host_ip_address in the command. The host ip address is automatically discovered. If you still have an issue with ucp v3.1.2, try the ucp v3.1.3.

I was trying to install the version 3.1.4 over AWS EC2 instance but doesn’t work. I’d tried again with the verision 3.0.7 and works fine. Somebody got today a solution about it ? Thanks

Thanks . Your steps helped me as well.

I think I am having the same issue with the 3.2.0-beta4, installation fails with : unable to run install step "Install Kubernetes Compose Plugin": unable to wait for Kubernetes Compose Plugin to be running: context deadline exceeded