Docker Community Forums

Share and learn in the Docker community.

Unable to run docker commands


(Pinkfloyd360) #1

Hi,

I’m running boot2docker on Yosemite on a Mac. I’m new to docker, but I’ve been exploring for the past two weeks and things were working fine. However, now I cannot issue any “docker” commands.

the server is up and my $DOCKER_HOST is setup correctly (tcp://192.168.59.103).

For example, when I try to run “$ docker ps” I get the following error:

~ $ docker ps
FATA[0032] Get http://192.168.59.103:2375/v1.17/containers/json: dial tcp 192.168.59.103:2375: i/o timeout. Are you trying to connect to a TLS-enabled daemon without TLS?

Any advice on how to go about troubleshooting this issue?

Best regards.


(Sven Dowideit) #2

yup :smile:
you need more than DOCKER_HOST

the best way to set all the right env, is to run $(boot2docker shellinit)


(Pinkfloyd360) #3

Thanks Sven for replying. All the variables are set correctly.

I’m getting the same error even when I run $(boot2docker shellinit).


(Pinkfloyd360) #4

BTW, I’m able to run all commands successfully when I’m in “boot2docker ssh”.


(Leonid) #5

Did you solve this?
We are having the same issue.


(Andy Rothfusz) #6

Ok, so that should mean that the daemon is still running in the VM.
Can you look at VirtualBox settings and see what the IP address for the VM is? Does it match the DOCKER environment variables?