Docker Community Forums

Share and learn in the Docker community.

Unable to use --log-opt mode=non-blocking .. gives error docker: Error response from daemon: unknown log opt 'mode' for syslog log driver

docker

#1

Steps to recreate:

  1. Execute the following command : echo “{ “insecure-registries”:[“xxxx:xxx”], “log-driver”: “syslog”, “log-opts”: { “syslog-address”:“udp://127.0.0.1:11514”,“mode”:“non-blocking”, “syslog-format”:“rfc3164”, “tag”:“stream.cosmos”} }” > /etc/docker/daemon.json;

  2. sudo service docker restart

3.docker run -it --log-opt mode=non-blocking --shm-size 34G imagexxxx /bin/bash

Can some one please help me set this option