Unable to use the volume flag with a windows container

I am trying to map a host folder to the guest in the same way that is easily accomplished on linux/mac via -v "$(pwd)":/code. I can’t come up with a simple example to make this work with Windows Containers.

docker build -t="webdav" .
docker run --rm -it -v C:\junk:C:\code --name webdav webdav powershell

C:\Program Files\Docker\Docker\Resources\bin\docker.exe: Error response from daemon: container f0fa313478fddb73e34d47699de0fc3c2a3bdb202ddcfc2a124c5c8b7523ec09 encountered an error during Start: failure in a Windows system call: The connection with the Virtual Machine hosting the container was closed. (0xc037010a).

I have tried countless other variations, and the accepted answer here gives the same error.

The docs seem to only refer to Docker Toolbox. The example only gives me invalid bind mount spec.

My Dockerfile

FROM microsoft/windowsservercore

RUN powershell -Command Add-WindowsFeature Web-Server

RUN powershell -Command mkdir /code

ADD * /code/

OS Name: Microsoft Windows 10 Pro
OS Version: 10.0.14393 N/A Build 14393

Version 17.03.1-ce-win5 (10743)
Channel: stable

This is solved. You cannot mount a folder that exists: stackoverflow