Docker Community Forums

Share and learn in the Docker community.

Unauthorized: incorrect username or password

This solves the problem.

I wish someone would ping this as an answer to the top.

Thank you.
It worked

1 Like

Thank you! Worked a like a charm

Thanks that worked for me.

Using my Docker Hub “username” instead of email worked for me too. Thanks.

Thanks, saved me a headache!

Over a year later, and your reply is still helping fix busted logins on MacOS.

Thank you! :raised_hands:

In my case docker was logged using my email address which apparently doesn’t work.

docker logout
docker login --username <username not email>

Did it for me.

2 Likes

Thanks for posting this. I was pulling my hair out trying to figure out why this was failing. What I do not understand is how/why Docker doesn’t log in with an email address vs. a simple username (the former being more unique) – or allowing both. Seems like a no-brainer to me. But I’m glad I figured this out.

1 Like

Excellent - the lower case tip was primo!

Thanks @antopjoseph, it works

1 Like

Your a boss bro. This worked for me. What a dumb error

1 Like

Thank very much! I addressed my problem.

  1. sign out form GUI
  2. sing in from CLI
    Thanks again :slight_smile:

Hi hugodahi, Thanks . my issue got solved , but how come you found this solution ?

Issue solved on mac. Thanks alot!

This worked for me. Thanks

The future has spoken (Aug 2019) and this is still helpful!

1 Like

I ran into the same problem, in my case I used the correct usename, still same problem. It suspect this was due to a special characted in my password. I could still use my password on the website, but this password did not work when attempting to log in through tray icon or using >docker login.

Just thought Id share in case someone else runs into this problem.

Thanks, it helped me a find the solution. In my situation, my password had ​a special character with bad behavior.