Docker Community Forums

Share and learn in the Docker community.

Unexpected EOF on auth.docker.io when trying to pull from docker hub

As of this morning, I am getting “Unexpected EOF” errors on docker pulls.

The error in full:

> docker pull microsoft/mssql-server-linux:2017-GA
Error response from daemon: Get https://registry-1.docker.io/v2/microsoft/mssql-server-linux/manifests/2017-GA: Get https://auth.docker.io/token?account=avonh&scope=repository%3Amicrosoft%2Fmssql-server-linux%3Apull&service=registry.docker.io: unexpected EOF

… it doesn’t matter which image I try to pull, I always get that error. The error seems not be with docker hub, though, as directly GETing that URL with wget works.

Any pointers, anyone? I have already tried deleting all images as suggested in a likely issue, but no luck so far.

docker desktop 2.2.0.4 (43472) on Windows 10 Pro Version 1903

2 Likes

Getting images from a different registry does work, so maybe the problem is with docker hub after all?

How did your resolve this issue? I have that too.
I also have the issue when pulling from other registries, i.e. mcr.microsoft.com.

I didn’t. I gave up after three days of trying various things, and now am just using Docker on Linux. I did not try reinstalling the entire machine, that would have been my last option had I not had the option of simply using another machine for that work.

Mark the issue as fresh with /remove-lifecycle stale comment.
Stale issues will be closed after an additional 30d of inactivity.

Prevent issues from auto-closing with an /lifecycle frozen comment.

If this issue is safe to close now please do so.

/lifecycle frozen

This is an active issue, and needs resolving.

I suspect this issue is still active for you, I am having the same problem.

I was suggested a solution for this problem in my GitHub issue on this topic:

I had this same issue. My problem was that I had the Docker CLI installed directly on WSL.
I switched docker for windows back to Hyper-V, then uninstalled the Docker CLI from WSL. After turning back on WSL integration everything worked.

This fixed it for me, maybe it helps you too