Docker Community Forums

Share and learn in the Docker community.

Unlock Docker Desktop

Hi all

My organization has taken an account on Docker and send me an invitation link. I’ve create my account (a new one) and is now part of the organization.

On Docker Desktop, I’ve made sign out (my old, free, account) and sign in with my new one and … what should I do to unlock Docker Desktop. Seems he think I’m still a free user but that’s not true.

You can see this on the image below.

  1. I’ve made a login on Docker Hub with my new account.
  2. We can see I’m part of an organization
  3. Docker Desktop still think that I’m a free user using a personal plan.

Thanks!

Just an idea. Try this from powershell or command line:

hub-tool.exe login

hub-tool.exe account info

If it shows the same “personal plan” then the issue is probably not the Desktop.

1 Like

Thank you Ákos !!!

You probably point me in an interesting direction : it’s impossible to make such login, I get this error: Error: failed to authenticate: bad status code “400 Bad Request”: malformed request: EOF

docker-hub --version return me Docker Hub Tool v0.4.1, build 5051946 and thus an older version (latest is 0.4.4)

I then see an issue for this on GitHub cannot login: Error: failed to authenticate: bad status code "400 Bad Request": malformed request: EOF · Issue #191 · docker/hub-tool · GitHub and they said it’s solved while it’s not on my machine.

By downloading the exe from GitHub and saving it to my c:\temp folder (my computer is managed by my company, I can’t overwritte the original file); it’s OK i.e. I can start c:\temp\hub-tool.exe and make a login.

So, next step for me, is to contact my intern helpdesk and ask to upgrade Docker desktop / hub-tool.

Thanks Ákos !

I hope it will help, but I don’t think so, because the hub-tool is relatively new. Docker desktop was there before hub-tool so I don’t think it needs to have it in order to login.

My current version of Docker Desktop is pretty old (4.x, updates are managed by IT too). I’ve asked them to add the newer version in our “software center”; then I can check with version 4.3.1. Will see…

Problem solved by installing the newer version of Docker Desktop (4.3.1).

Many thanks for pointing me to the right direction.

1 Like