Docker Community Forums

Share and learn in the Docker community.

Vpnkit is using port 80, can we tell it to use something else?

docker
beta

(Pulkit Singhal) #1

I wanted to use docker-compose to run nginx and expose port 80 on my localhost but I ran into an error that port 80 was already in use.

When I looked further I saw vpnkit using it:

$ sudo lsof -i -n -P | grep TCP | grep vpnkit
vpnkit 25u IPv4 0x… 0t0 TCP *:80 (LISTEN)

A tiny bit of googling says that vpnkit is used by docker. As an experiment, I shut off the docker beta on mac … then ofcourse the port becomes available again … Hurray … but now: No docker! :confused:

What to do? Can I tell vpnkit to use a different port?


(Pulkit Singhal) #2

A friend using 17.03.1-ce-mac5 (16048) did not experience this problem.

My build at the time of reporting this problem was 17.05.x-xx-xxx (17656)

After resetting docker and upgrading to 17.06.0-rc1-ce-mac13 (18169) this doesn’t seem to be a problem anymore … shocking, i know!

Leaving this note here, in case it helps some other random traveler.


(Ryanore) #3

I actually had the same problem on 17.09.0-ce-mac35 . (using port 80).

Your message prompted me to check for updates, but I was already up to date, so the next obvious step… Turn it off and turn it back on again. What do ya know?

Restarting docker fixed it. Thanks for posting this, probably saved me a ton of time.


(Pulkit Singhal) #4

I’m glad it helped you. Its great to be part of this community.


(Ashwin Murali) #5

I still see this error. Restarting the Docker app doesnt seem to do anything.

$ docker version
Client:
 Version:      17.09.1-ce
 API version:  1.32
 Go version:   go1.8.3
 Git commit:   19e2cf6
 Built:        Thu Dec  7 22:22:25 2017
 OS/Arch:      darwin/amd64

Server:
 Version:      17.09.1-ce
 API version:  1.32 (minimum version 1.12)
 Go version:   go1.8.3
 Git commit:   19e2cf6
 Built:        Thu Dec  7 22:28:28 2017
 OS/Arch:      linux/amd64
 Experimental: true