Docker Community Forums

Share and learn in the Docker community.

Webhooks, https


(Hansenms) #1

Hi,

I have been playing with some webhooks. Basically I want to fire a webhook when a new image is uploaded to a repo. It works fine for http, but when I use https it fails with just an exclamation point. I have tried with a self-signed certificate following somewhat along the lines of this http://nathanleclaire.com/blog/2014/08/17/automagical-deploys-from-docker-hub/ description but using a python flask app. I have also gotten a signed certificate since I thought that might be the problem, but no luck. So my questions are:

  1. Do the webhooks work with https, are there any examples you can point to for a working listener.
  2. Can one use self-signed certificates or do I need a signed one.
  3. Is there any way of debugging what error message (the exclamation point is not that informative).

Any help or hints would be appreciated.

Thanks,
Michael


(Giladtwist) #2

Hey Michael,
I’ve encountered the same issue.
Did you find an answer to whether webhook work with self-signed certificates?

My guess is they don’t, as I tried it with 2 endpoints, my GCP instance and facebook.com. Facebook worked well, and mine didnt, but I still try to verify that my instance isn’t badly configured.