Docker Community Forums

Share and learn in the Docker community.

Why doesn't this mounted volume work?


#1

I can’t get mounting to work. I tried Windows(toolbox) & linux, php & coldfusion)

On windows I ran docker toolbox and made a simple index page in coldfusion as an example. It renders fine. However when I make a change to the index file, the rendering doesn’t update until I rebuild.

Dockerfile: (cd C:\Users\public\dockertest)

FROM   lucee/lucee52-nginx:5.2.5.20
COPY src/ /var/www/html
EXPOSE 80

toolbox commands: (cd /c/Users/public/dockertest)

$ docker build test .
$ docker run -p 80:80 -v /c/Users/public/dockertest/src:/var/www/html test

This doesn’t render the changes in the index.cfm file unless I do the following:

$ docker ps

output: 1 container running with id: 5035e4d1739a

$ docker stop 5035e4d1739a
$ docker build test .
$ docker run -p 80:80 -v /c/Users/public/dockertest/src:/var/www/html test

Note that I am using Docker toolbox and not Docker for Windows.
I have been stuck on this for several days so any help is more than welcome.


(Ntweekly) #2

Hi there,

You have a few options: