Docker Community Forums

Share and learn in the Docker community.

[Windows 7 64bits] - Docker compose error : ERROR Couldn't find a package.json file in "..."

Hello,

I am going crazy with this issue.

I joined a project where the team is using docker. I retrieved the sources and the dockers files from our repositories

I am on Windows 7 PRO, so I had to install Docker Toolbox (as Docker Desktop is only for Windows 10).
Therefore, I am using the linux bash integrated to run my commands.

There are 4 containers :

  • 1 Api in node.js - * 1 DB PostGreSQL - * 1 for PGadmin - * 1 for a third-party service

When i run ‘docker-compose up -d’, all the containers launch correctly, except the API.

I keep having this error :

yarn run v1.13.0
error Couldn’t find a package.json file in “/c/Users/heretyk/Documents/Dropbox/Coding/Roote/API”

I don’t understand because i launch the command from the project folder, and when i do “ls”, i see package.json.
I even tried a CHMOD 777 -R ./

Anyone could help please ? I am driving crazy and i can’t work with docker running…
Is this an incompatibility with Windows 7 PRO ?

Thanks.

—Environment info —

‘Dockerfile’ :

FROM node:10.15.1-slim

RUN userdel node

ARG UID=197608
RUN useradd --uid $UID --create-home app
USER app

WORKDIR /c/Users/heretyk/Documents/Dropbox/Coding/Roote/API/

COPY package.json /c/Users/heretyk/Documents/Dropbox/Coding/Roote/API/

ENV PATH="/c/Users/heretyk/Documents/Dropbox/Coding/Roote/API/.bin:${PATH}"

CMD ["yarn", "start"]

OS VERSION :

OS Name:                   Microsoft Windows 7 Ultimate
OS Version:                6.1.7601 Service Pack 1 Build 7601

DOCKER TOOLBOX CLIENT & ENGINE VERSION :

Client:
 Version:           19.03.1
 API version:       1.40
 Go version:        go1.12.7
 Git commit:        74b1e89e8a
 Built:             Wed Jul 31 15:18:18 2019
 OS/Arch:           windows/amd64
 Experimental:      false

Server: Docker Engine - Community
 Engine:
  Version:          19.03.1
  API version:      1.40 (minimum version 1.12)
  Go version:       go1.12.5
  Git commit:       74b1e89e8a
  Built:            Thu Jul 25 21:27:55 2019
  OS/Arch:          linux/amd64
  Experimental:     false
 containerd:
  Version:          v1.2.6
  GitCommit:        894b81a4b802e4eb2a91d1ce216b8817763c29fb
 runc:
  Version:          1.0.0-rc8
  GitCommit:        425e105d5a03fabd737a126ad93d62a9eeede87f
 docker-init:
  Version:          0.18.0
  GitCommit:        fec3683