With "docker-compose up" --no-deps flag doesn't work

I’m using Docker Engine v20.10.13 and configured all the applications under compose file. In compose file, we have a dependency map and in few cases, we don’t want to run all the dependencies.

For this reason, when we use “–no-deps” flag, it still starts all the dependencies. In earlier versions, it was working as expected but with new releases it has stopped behaving like that.

1 Like

I’m experiencing the same behavior with Docker Engine 20.10.14 and Docker Compose version v2.4.1. Was working fine before as well ¯_(ツ)_/¯

Can you show, how you run it exactly? I tried v2.4.1 and previous versions also, but all of them worked for me.
On which operating system are you running it? Does it happen with every compose file or just one specific file?

The only thing I noticed, that even if the dependency started (when I wanted it to start) its log messages didn’t show up, but I tried with only one file so could make a mistake somehow.

Seems to be working again with Docker Compose version v2.5.0 ¯_(ツ)_/¯