Docker Community Forums

Share and learn in the Docker community.

Write /mnt/sda1/.... read-only file system

docker

(Kendallarneaud) #1

Expected behaviour

Should pull and save image to machine

Actual behaviour

Error message while using docker pull to pull and save an image to the container

write /mnt/sda1/var/lib/docker/tmp/GetImageBlob506981519: read-only file system

Software/ Hardware information

OSX Yosemite
VirtualBox 5.0.24
Docker 1.12.11 (Homebrew)
Docker-MAchine version 0.8.1, build 41b3b25

Issue description

I’m trying to run docker containers off of a network drive on my home network. I’m able to create a default machine but have to keep chmod 0600 ida_rsa in order to get ssh on every new default container created.
But the problem really starts when trying to download an image to the machine and upon reaching some % of download getting a

write /mnt/sda1/var/lib/docker/tmp/GetImageBlob506981519: read-only file system

running a demsg in the machine give me this log file output

I have tried removing and reinstalling but eventually run back into the same problem

I’m new to docker and not as apt with server administration. Is there any solution to this problem???


(David Maze) #2

Are you sure your NAS drive is healthy? The last couple of lines of that dmesg output look to me like, at best, there’s disk corruption (and you need to take the drive offline and fsck it), and at worst, the hardware is failing. This doesn’t look like a Docker-specific error to me.


(Kendallarneaud) #3

Tried running off of a MSD card and still get the same thing the dsmeg revealed this message