Docker Community Forums

Share and learn in the Docker community.

Yum command not working in docker container


(Imranv10) #1

Hi
I
have created an image successfully and when I tried to run in a
different container. Container is started but yum command is not working
in container.

While on host server, I am able to connect to internet without any problem.

And I am getting this message

Loaded plugins: fastestmirror
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=stock error was
14: curl#6 - “Could not resolve host: mirrorlist.centos.org; Unknown error”

One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Disable the repository, so yum won't use it by default. Yum will then
    just ignore the repository until you permanently enable it again or use
    --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>

 4. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: base/7/x86_64

I have tried
docker run --dns 8.8.8.8
DOCKER_OPTS="–dns 8.8.8.8".
I have also tried with below steps (to reset network settings)

pkill docker
iptables -t nat -F
ifconfig docker0 down
brctl delbr docker0
docker -d

When I did IP forward
sysctl -w net.ipv4.ip_forward=1
I am able to ping but still yum command is not working.

Please guide me.

Thanks


(Sven Dowideit) #2

What distribution and OS version are you running?

can you paste the output of docker info and docker version please?


(Sven Dowideit) #3

on the boot2docker test env i just made, it seems to work, so its going to be host related.

docker@boot2docker:~$ docker run --rm -it centos  yum update
Loaded plugins: fastestmirror
base                                                                                               | 3.6 kB  00:00:00
extras                                                                                             | 3.4 kB  00:00:00
updates                                                                                            | 3.4 kB  00:00:00
(1/4): extras/7/x86_64/primary_db                                                                  |  43 kB  00:00:00
(2/4): base/7/x86_64/group_gz                                                                      | 157 kB  00:00:00
(3/4): base/7/x86_64/primary_db                                                                    | 4.9 MB  00:00:16
(4/4): updates/7/x86_64/primary_db                                                                 | 6.6 MB  00:00:16
Determining fastest mirrors
 * base: mirror.aarnet.edu.au
 * extras: mirror.aarnet.edu.au
 * updates: mirror.aarnet.edu.au
Resolving Dependencies
--> Running transaction check
---> Package tzdata.noarch 0:2014j-1.el7_0 will be updated
---> Package tzdata.noarch 0:2015a-1.el7_0 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================================================
 Package                   Arch                      Version                             Repository                  Size
==========================================================================================================================
Updating:
 tzdata                    noarch                    2015a-1.el7_0                       updates                    432 k

Transaction Summary
==========================================================================================================================
Upgrade  1 Package

Total download size: 432 k
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
warning: /var/cache/yum/x86_64/7/updates/packages/tzdata-2015a-1.el7_0.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID f4a80eb5: NOKEY
Public key for tzdata-2015a-1.el7_0.noarch.rpm is not installed
tzdata-2015a-1.el7_0.noarch.rpm                                                                    | 432 kB  00:00:00
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7
Importing GPG key 0xF4A80EB5:
 Userid     : "CentOS-7 Key (CentOS 7 Official Signing Key) <security@centos.org>"
 Fingerprint: 6341 ab27 53d7 8a78 a7c2 7bb1 24c6 a8a7 f4a8 0eb5
 Package    : centos-release-7-0.1406.el7.centos.2.5.x86_64 (@Updates/$releasever)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7
Is this ok [y/N]: y
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : tzdata-2015a-1.el7_0.noarch                                                                            1/2
  Cleanup    : tzdata-2014j-1.el7_0.noarch                                                                            2/2
  Verifying  : tzdata-2015a-1.el7_0.noarch                                                                            1/2
  Verifying  : tzdata-2014j-1.el7_0.noarch                                                                            2/2

Updated:
  tzdata.noarch 0:2015a-1.el7_0

Complete!

(Imranv10) #4

Thanks for reply.
It was network issue.
Network administrator has removed internet connection from that VM and allowed only ping access. That is why I was facing this issue.
Issue is resolved now.

Thanks for support.


(Joshipiyush217) #5

Hi
I am also facing the same issue. Saw your final reply. Cannot understand the statement “Network administrator has removed internet connection from that VM and allowed only ping access”. Please explain in detail


(Cleverlzc) #6

Hi,
I am also facing the same issue. How did you solved this problem? @imranv10


(Cleverlzc) #7

I just have solved this. Just do copy the host yum source file CentOS-Base.repo to docker image innerly.


(ianjuma) #8

It’s also possible that the docker bridge is lost/ not present in the machine.
List with ip link. restarting the docker service worked for me.