'yum install docker-engine' fails with audit-libs-2.4.1-5.el7.i686 != audit-libs-2.4.5-3.el6.x86_64

Hi Al,

I’m following this page for docker installation on CentOS 7:

I upgraded the kernel:
$ uname -r

however, when i run yum command i’m getting this:

–> Running transaction check
—> Package audit-libs-python.x86_64 0:2.4.1-5.el7 will be installed
–> Processing Dependency: audit-libs = 2.4.1-5.el7 for package: audit-libs-python-2.4.1-5.el7.x86_64
—> Package libselinux-python.x86_64 0:2.2.2-6.el7 will be installed
—> Package libsemanage-python.x86_64 0:2.1.10-18.el7 will be installed
—> Package python-IPy.noarch 0:0.75-6.el7 will be installed
—> Package setools-libs.x86_64 0:3.3.7-46.el7 will be installed
–> Running transaction check
—> Package audit-libs.i686 0:2.4.1-5.el7 will be installed
–> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

   Protected multilib versions: audit-libs-2.4.1-5.el7.i686 != audit-libs-2.4.5-3.el6.x86_64

I can’t erase the audit-libs-2.4.5-3.el6.x86_64 because it looks like it’s linked to the whole system include systemd which is protected.

What to do?

also, when i run:

sudo yum install audit-libs-2.4.1-5.el7.i686 --setopt=protected_multilib=false

i’m getting this:

Transaction check error:
package audit-libs-2.4.5-3.el6.x86_64 (which is newer than audit-libs-2.4.1-5.el7.i686) is already installed

not sure what to try next…