Docker Community Forums

Share and learn in the Docker community.

403 Forbidden when I run docker


(Ronandquinn) #1

Hi
I am totally new to docker, and have been set the task of using it for a uni lab, without any instruction or assistance of any kind from the lecturer. The lab is due in a few days, and I am stuck just getting started with docker on my mac, and I can’t find the solution elsewhere, or work it out for myself, as I’m so new to it.
I’ve got docker running ok, verified by running the nginx server, but I’ve tried to create and run a basic, one line, hello world php container, and instead of finding “Hello World” displayed to screen, I’ve got:

“403 Forbidden You don’t have permission to access / on this server.
Apache/2.4.10 (Debian) Server at localhost Port 80”

Why is this?

My lab says
"Configure [docker] so you do not need administrative privileges to make it run (e.g. sudo)"
But it doesn’t say how to do this, or how to do anything else.

Could this be the reason?
Sorry for such a dumb question, but I’m getting desperate
Thank you