Docker Community Forums

Share and learn in the Docker community.

404 Error while pulling image from docker hub

Hi,
I’m getting 404 error when pulling docker from docker hub.
I’m using image id with registry because in CI system I have private registry configured as default one.
Yesterday, next command worked:


docker pull registry.hub.docker.com/library/python:3.8

today, I’m getting next error


Error response from daemon: error parsing HTTP 404 response body: invalid character '<' looking for beginning of value: "<!doctype html>\n<html lang=\"en\">\n\n<head>\n    <meta charset=\"utf-8\">\n    <title>404 : Docker</title>\n
...

Has anything changed in docker hub settings recently?
I have similar issue while pulling other images from hub.docker.com.

Hello,

we get the same error since today.

docker pull registry.hub.docker.com/amazon/aws-efs-csi-driver:778131e
Error response from daemon: error parsing HTTP 404 response body: invalid character '<' looking for beginning of value: "<!doctype html>\n<html lang=\"en\">\n\n<head>\n    <meta charset=\"utf-8\">\n    <title>404 : Docker</title>\n    <meta name=\"viewport\" content=\"width=device-width, initial-scale=1\">\n    
...

is there a reason why you define the full fqdn to hub.docker?
What happends if you use: docker pull amazon/aws-efs-csi-driver ?

In my case I’m defining fqdn, because Jenkins in configured in that way, if no registry is provided, the private one is used.
So docker pull without registry works on my local machine, but not on the Jenkins’ node, because it tries to pull from private-repo/organization/docker-image.

docker pull amazon/aws-efs-csi-driver:778131e

works local. But the fqdn is defined in the OpenShift operator. So I can’t change this.
Pulling with docker pull registry.hub.docker.com/amazon/aws-efs-csi-driver:778131e worked the last months.

Hello we have encoutred the same problem.

Quick fix for it is to change the registry url:
Instead of registry.hub.docker.com, put here index.docker.io

In the CI you have to update your DOCKER_AUTH_CONFIG with index.docker.io auth property in order to be able to auth.

Does anybody have some clues about what happened?

Seems to be working again

See this:

Yes. works also for me.

1 Like