Accessing my Docker for Mac container from within a Windows VM

I do some windows development in a VMWare Fusion and connect to my mac for redis/mongo since I want to minimize what I run in a VM.

Before, with Docker Machine, I ran boot2docker in another VMware VM and both VMs were in the same subnet, so I was able to connect directly to those Redis/Mongo instances from the Windows VM.

Now with docker for the mac, since everything’s mapped to localhost, I can’t really figure out which IP to use to address the actual container. I called docker inspect and got an IpAddress but I can’t connect to my redis instance using that IP address.

Expected behavior

Connect to mac container from my Windows VM using the IP in docker inspect

Actual behavior

Can’t do the above.


OS X: version 10.11.5 (build: 15F34) version v1.11.1-beta13 Running diagnostic tests: [OK] Moby booted [OK] driver.amd64-linux [OK] vmnetd [OK] osxfs [OK] db [OK] slirp [OK] menubar [OK] environment [OK] Docker [OK] VT-x Docker logs are being collected into /tmp/20160527-101106.tar.gz Most specific failure is: No error was detected Your unique id is: A4A135D8-ED56-4C14-8697-15E13BCADD3F Please quote this in all correspondence.

Steps to reproduce the behavior

I launch my containers, and then I launch my windows VM, and my tests fail since they can’t connect to the redis server.

With the latest beta, I just point my Windows VM at my Mac’s ip address (the one from the router), and it works great. :slight_smile:

@atonse Did you get this working? I am having the same issue and unable to figure out how to access the container from Windows VM on a Mac