Docker Community Forums

Share and learn in the Docker community.

Accessing Windows Shares From Within A Container


(Bzowk) #1

Hey Guys -

I currently have a dedicated Docker host running Atomic Fedora 28 - which I love. There’s been one roadblock I haven’t been able to resolve, though.

Many of the containers I wish to use are ones related to media which can only be accessed from a Windows Share. Despite attempts, I’ve been unable to get containers to access files on a share. Below is what I recently tried and the results.

Using CIFS on the host (Atomic Fedora 28), I mounted the Windows share with full permissions, verified it worked after mounting, then added the path I mounted it on to the container as a mounted volume. When trying to start the container after doing so, I get the error:

container_linux.go:247: starting container process caused “process_linux.go:258: applying cgroup configuration for process caused “mountpoint for devices not found””

If I remove the mounted volume or unmount the share from the host, the container starts normally and works great. I’ve also tried to install CIFS utils within containers and mount the shares internally, but have been unable to do this as well as I’ve found that Docker prevents this behavior.

Given the above, what is the best method (or a working one) which would allow interaction with Windows shares as described?

Thank You!

UPDATE

I read that adding the string below will allow mounting within a container so tried it:`

–cap-add SYS_ADMIN --cap-add DAC_READ_SEARCH

However, when trying to mount within the container after adding that, I get “no such device”. I can ping the host from within the container, verified the shares settings, verified permissions, etc.

Any ideas? Thanks


(Victorbarajas89) #2

Maybe this could help you https://github.com/docker/compose/issues/2837


(Bzowk) #3

Good Afternoon -

I really appreciate the reply and gave it a shot, but no go. Seeming, it all comes down to me running Atomic.
When trying to mount the network share, I got a message saying that a plugin wasn’t found and discovered that I had to install “docker-volume-netshare.” Unfortunately, they do not provide .rpm releases and in Issues I saw that someone who tried converting the provided .deb to an .rpm had it fail during installation. I made a post in Issues so hopefully will get a reply, but we’ll see.

Surely what I’m trying to do is a common thing. Any other suggestions? Thank Again!