Docker Community Forums

Share and learn in the Docker community.

Connecting Linux container to Windows network share

Greetings folks,

 I'm still really new to docker, and in general have limited linux experience, so forgive me.  

 I'm having issues getting a linux docker container to connect to a windows network share.  It just acts like it cannot see the share.  when i try to mount the share to a local folder in the container via kitematic i must use the UNC name of the share.  If i try mounting the share as a mapped drive, or as a symbolic link on the system i get the prompt to share the drive, then the container crashes.  using the unc it appears to mount, but nothing happens and according to the container, the directory looks empty.  I have tried installing cifs-utils and key-utils and manually mounting the drive, but i get the error "Unable to find suitable address.  I've even tried adding a macvlan with a static IP to the container and it made no difference.  I can get the container to work correctly with a local directory on the host just fine, but that wont work for what i need.  Any ideas?

for a bit of context. Im running lancache-monolithic, lancache-dns, and sni proxy in docker. I have a DFS share set up to replicate the cached content, and have a NFS cluster set up to load balance the traffic. It’s this nfs/dfs share im trying to mount to the lancache-monolithic container.